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Very slow performance running lessons or admin/teacher functions



Article ID 9923
Product PLATO Learning Environment (PLE)
Issue You experience very slow performance running lessons or using administrator or teacher functions.
Resolution Run connection tests, including MySpeed, to check for insufficient bandwidth or packet loss; contact your IT group or PLATO Support

Details

Resolution

How to diagnose performance or connectivity problems:    Contact your IT group or PLATO Support for further help:  

  1. Check system requirements:   Determine whether your connection to the Internet meets the system requirements for the PLATO product that you are using: http://support.plato.com/requirements.asp

  2. Test connection speed to check for insufficient bandwidth or packet loss:  

    Test your connection speed using Visualware's MySpeed test:
    http://myspeed-sd.platoweb.com/

    a. Click  "San Diego".


    b. Click  "One time test (May be more compatible with firewalls)".


    c. Click "Click to start test".


    d. When the test is done, click "Click here for detailed analysis."


    e.  Copy the link in the address bar (i.e.  "http://myspeed-sd.platoweb.com/myspeed/db/report?id=xxxx")


    f.   Email this link to support@plato.com; make sure to put your case  number in the subject line.


  3. Refer to the MySpeed section below for how to interpret the results.

  4. After confirming a  bandwidth problem, use additional diagnostic tools (tracert and ping) to  narrow down the source.     See Additional Tools below.

  5. Measure the effect of more simultaneous users.    Compare performance with one student vs. many at a time.   Compare the speed with one student using the product with the speed when many or all students are using it at the same time. If the connection speed is much slower with students in the lab, then it appears that your bandwidth (capacity for simultaneous traffic) is limited.

  6. Compare speed within vs. outside  your local network.   Ask your IT group to compare the time it takes to load a page in their network with the same page outside their network.

  7. Empty proxy server cache.   If you are using a proxy server, empty the cache. Configure your proxy server so that the cache is bypassed for all platoweb.com requests.  

  8. Learn more about bandwidth.   Refer to the following document about bandwidth:   How Much is Enough?  

  9. Contact PLATO Support to see if we experience the same delay accessing your account.


 MySpeed  - What is tested and how to do I understand the results of Visualware's MySpeed test?

 

  •  Why is a direct socket-to-socket connection test more accurate than an HTTP test?

The difference in results is due to the different layers of the OSI model. A direct socket-to-socket connection works at the lower TCP transport layer. A HTTP connection uses a browser which works at the application layer and is subject to factors such as browser caches and proxies which can affect results, particularly on high speed networks.

The socket-to-socket download and upload speed tests provide the most accurate speed tests available. The standard HTTP speed test will be used as a backup, in case a client's firewall prevents direct socket connections to the MySpeedServer ports.

 

 

 

 

 

 

 

 

 


 

HTTP Speed Tests: MySpeed measures actual HTTP data transfer performance -- not rated network speeds. Since there will always be some overhead associated with a network connection, you can expect results on high quality networks (and reasonably fast computers) to approach around 95% of the rated download speed and around 92% of the rated upload speed, similar to the following:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When MySpeed was tested in a local 100 Mbps LAN environment, with a client connected to the server via a 10/100 Mbps switch with various speed and duplex settings, the following 'download/upload' results were observed (all numbers are in Mbps):

 

 

 

 

 

 

 

 

 

 

Please note:

(1) The CPU speed of the server and/or client used can dramatically affect the results.
(2) The upload results for 100 Mbps are displayed for reference only - even though we only rate MySpeed HTTP upload accuracy to 10 Mbps.  

  • What are the sample download/upload file sizes?

The sockets (if possible) are configured for large buffers, and up to 10 MB is transferred both ways during the 8 second time limit.

    Download: The default file used for the download speed test is a fully compressed 10Mb file.

    Upload: Multiple upload sizes, ranging in size from 8 KB to 128 KB (size depends upon the web server used and your Internet connection speed), but with an 8 second timeout.

    Timeout: The timeout value is 8000 milliseconds (8 seconds).  

    • What are the sample download/upload file sizes?

    The sockets (if possible) are configured for large buffers, and up to 10 MB is transferred both ways during the 8 second time limit.

      Download: The default file used for the download speed test is a fully compressed 10Mb file.

      Upload: Multiple upload sizes, ranging in size from 8 KB to 128 KB (size depends upon the web server used and your Internet connection speed), but with an 8 second timeout.

      Timeout: The timeout value is 8000 milliseconds (8 seconds).  

      Quality of Service (QOS): If these graphs represent typical download rates over time from two different broadband Internet providers, both providing an average of 3 Mbps, which service provider should get the higher quality of service rating?

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

      The first provider (A) should win hands down and that is the basis for the MySpeed Quality of Service measurement. Being able to provide a consistent download capacity is what quality of service is all about. The MySpeed Quality of Service measurement is a very simple calculation:

       

      Minimum speed /Maximum speed = Quality of Service

       

      This is just the minimum speed observed during a large download divided by the maximum speed observed, resulting in a percentage number from 0 (worst) to 100 (best). The higher the percentage, the better the quality of service. Variation in the download rate is undesirable and is penalized (resulting is a lower percentage number).

      In the example graphs above, the QOS for provider A is 100% (5/5), whereas the QOS for provider B is 20% (1/5).

      Please note that the MySpeed QOS percentage is independent of line speed. The above graphs could be Kbps instead of Mbps and the providers would still obtain the same QOS numbers. This is by design. The MySpeed QOS metric measures line quality, not line speed.

      T1 Line: For example, on a virtually unused T1 line (1.544 Mbps), MySpeed repeatedly reported a download speed of 1.46 Mbps and an upload speed of 1.44 Mbps, and as you expect, a QOS in the upper 90's.

      DSL: On a DSL connection, you can expect to see a consistently high QOS number (when you are the only person using the DSL connection). If you don't, contact your DSL provider to file a problem report.

      Cable Modem: On a high quality cable modem network, you can expect a QOS in the 90's or 80's. However, because you have the potential for sharing your connection with everyone in your neighborhood, some low quality networks will see lower numbers, sometimes even below 10.  

      • What is jitter?

      Jitter is a key measure of VoIP quality. Jitter refers to is the variation in time between packets sent and packets arriving caused by network difficulties such as route changes, congestion, packet loss, traffic regulators etc. VoIP works by sending voice data as a stream of packets from source to destination. These packets can take a varying amount of time to reach the destination and invariably do not arrive in the order in which they were sent.

      For a VoIP telephone call to work well, the packets sent from the source must arrive within a certain time window (or "buffer") in order for the receiving end to reassemble the packets in the correct order and reproduce the spoken words. When there is excessive jitter the time delay is too long (high latency) and packets arrive outside the time window and get lost from the call (discarded). As a result, the recomposed sound no longer reflects exactly what was sent, and depending of the extent of the delay may not be understandable by the recipient. MySpeed Server VoIP measures the level of jitter on a connection and reports the associated level of VoIP sound quality.

      Packet loss plays a key role in the quality of VoIP connections, as high packet loss causes some of the voice data not to arrive to the recipient. Packet loss occurs when voice packets are discarded by the jitter buffer (see previous FAQ), or dropped by network routers/switches due to high congestion. MySpeed Server VoIP measures the percentage of packet loss and reports the associated level of sound quality.

       

      Causes:

      Packet loss can be caused by a number of factors, including signal degradation over the network medium, oversaturated network links, corrupted packets rejected in-transit, faulty networking hardware, maligned system drivers or network applications, or normal routing routines.

       

      Effects:

      When caused by network problems, lost or dropped packets can result in highly noticeable performance issues or jitter with streaming technologies, voice over IP, online gaming and videoconferencing, and will affect all other network applications to a degree. However, it is important to note that packet loss does not always indicate a problem. If the latency and the packet loss at the destination hop are acceptable, then the hops prior to that one don't matter.

       


       Additional Tools:   PING and TRACERT

       

       

      Now that you have confirmed that you have a connection issue, what are some tools that you can use to find out if this is a local issue or an issue outside of my network?

       

      Try a  TRACERT (trace route)  command to trace where a breakdown in your connection may be occurring.


       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

      For more information on using TRACERT, please refer to this Microsoft knowledge base article: http://technet.microsoft.com/en-us/library/cc779346.aspx

       

      If a TRACERT is able to trace without a problem, try using PING with a number of bytes and passes to determine if there is any packet loss.

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

      For more information on using  PING commands to troubleshoot your connection, please refer to  these Microsoft knowledge base articles:

      http://technet.microsoft.com/en-us/library/cc737478.aspx

      http://technet.microsoft.com/en-us/library/cc787365.aspx

       

       

       

       

       


      PLE Learn more about PLE! Use our Tutorial video series, Quick Start Guides and Quick Reference Cards to find out more about the features available to you.



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